Thursday, April 12, 2012

Unified Messaging Service Not Starting

After installing Unified Messaging Role on Exchange 2010 the Unified Messaging service is not starting.Getting below Error.

The Microsoft Exchange Unified Messaging service was unable to start. More information: "Microsoft.Exchange.UM.UMService.UMServiceException: No certificate was found using the thumbprint '' specified in the UMCertificateThumbprint property of the UMServer object.

at Microsoft.Exchange.UM.UMService.UMConnectionManagerHelper.TLSConnectionManager.Initialize()

at Microsoft.Exchange.UM.UMService.UMService.InitializeConnectionManager()

at Microsoft.Exchange.UM.UMService.UMService.StartService()

at Microsoft.Exchange.UM.UMService.UMService.OnStartInternal(String[] args)"

For this issue First thing you need to check poper certificate is available in local system.
If certificate availbale Follow the below steps.
Go to Exchange management Console
Open Server configuration
Click on Unified Messaging
Click on the server
Go to right pane
Click on Assign certificate option
Follow the wizard and select the decided certificate.
Start the Service again.. it is started right??????

Dont forget to put feedback.


  1. This worked great!

  2. This solved me exact problem. Thanks so much, man! -Eric